summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-01-14 20:03:15 -0500
committerCarlos Aznarán Laos2023-01-14 20:03:15 -0500
commita3b2f85197b76fef92c4b9b239f59f37c89cbb45 (patch)
treeb6c15ec6dd111721fc120a5e840854a8528f146d /PKGBUILD
downloadaur-a3b2f85197b76fef92c4b9b239f59f37c89cbb45.tar.gz
Bump version to 22.08.02
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..847c8b74556f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=cppimport
+pkgname=python-${_base}
+pkgdesc="Import C++ files directly from Python!"
+pkgver=22.08.02
+pkgrel=1
+arch=(any)
+url="https://github.com/tbenthompson/${_base}"
+license=('custom:BSD-3-clause')
+depends=(python-mako pybind11 python-filelock)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+checkdepends=(python-pytest)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha256sums=('c267cd7d8583631858e1fcf493018385725fa7c2c1d87113e5a49a9e70cb0269')
+
+build() {
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}