summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM. Greyson Christoforo2023-11-17 23:22:12 -0700
committerM. Greyson Christoforo2023-11-17 23:22:12 -0700
commit7257856763b7c99e91271ae06e93603473821402 (patch)
tree2b1c25d3da927ec3a387d77a33590ff46267132b /PKGBUILD
downloadaur-7257856763b7c99e91271ae06e93603473821402.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0855ffba4bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# $Id$
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+pkgname=python-cq-kit
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="A python library of CadQuery tools and helpers for building 3D CAD models."
+arch=(x86_64)
+url="https://github.com/michaelgale/cq-kit"
+license=('MIT')
+depends=(
+#TODO
+python-cadquery
+)
+makedepends=(
+python-build
+python-installer
+)
+
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/michaelgale/cq-kit/archive/refs/tags/v.${pkgver}.tar.gz")
+sha256sums=('f2a74b5c1b761d829512ca1b24bee8c7209cda9a1c9106e7c4db40ca58d09763')
+
+prepare() {
+ cd cq-kit-v.${pkgver}
+ rm -rf dist
+ #curl --silent https://patch-diff.githubusercontent.com/raw/gumyr/cq_warehouse/pull/37.patch | patch -p1
+}
+
+build() {
+ cd cq-kit-v.${pkgver}
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd cq-kit-v.${pkgver}
+ #python -m unittest -v # project currently configured incorrectly for this to work
+}
+
+package() {
+ cd cq-kit-v.${pkgver}
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}
+