summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPopolon2024-05-08 19:34:27 +0200
committerPopolon2024-05-08 19:34:27 +0200
commit9a846db3a089b21050e7b05a697c472dbd6b8c2b (patch)
tree576768f4cf3a478dc76b14507d7865de092aefd7 /PKGBUILD
parentc36be7d9cb31f10e768de6eff32cff604b8b5258 (diff)
downloadaur-9a846db3a089b21050e7b05a697c472dbd6b8c2b.tar.gz
upgrade to version 7.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c495d2c091a0..8427d3f88a5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,24 @@
pkgname='python-crc'
_module='crc'
-_src_folder='crc-6.1.1'
-pkgver='6.1.1'
+pkgver='7.0.0'
pkgrel=1
pkgdesc="Library and CLI to calculate and verify all kinds of CRC checksums"
url="https://github.com/Nicoretti/crc"
-depends=('python')
+depends=('python' 'python-poetry')
makedepends=('python-build' 'python-installer' 'python-wheel')
license=('custom:BSD License')
arch=('any')
-source=("https://files.pythonhosted.org/packages/34/d6/8f8d6ed8d8e71ad2f538058f2608dfed0312ca8a95c56c52b44fa99368fb/crc-6.1.1.tar.gz")
-sha256sums=('934085e4128a9d3079df70b70bca330e6d298c8a2191899903272f4e53f3220d')
+source=("https://github.com/Nicoretti/crc/releases/download/${pkgver}/${_module}-${pkgver}.tar.gz")
+sha256sums=('b9fc521042167f2b59d9183ce27acc0897e4a17748421e8b304ccdf7ebf4280a')
build() {
- cd "${srcdir}/${_src_folder}"
+ cd "${srcdir}/${_module}-${pkgver}"
python -m build --wheel --no-isolation
}
package() {
depends+=()
- cd "${srcdir}/${_src_folder}"
+ cd "${srcdir}/${_module}-${pkgver}"
python -m installer --destdir="${pkgdir}" dist/*.whl
}