summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Chen2015-12-10 16:19:32 +1300
committerAndrew Chen2015-12-10 16:19:32 +1300
commite3d97d3bc2d8026f45dd87a69f18e86b473d2ac5 (patch)
tree7e2e07d302a9b324984d5f9b271a45f50622a541 /PKGBUILD
downloadaur-e3d97d3bc2d8026f45dd87a69f18e86b473d2ac5.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76402a4e4c78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Andrew Chen <andrew.chuanye.chen@gmail.com>
+
+pkgbase=python-cstruct
+pkgname=('python-cstruct' 'python2-cstruct')
+pkgver=1.0
+pkgrel=1
+pkgdesc="C-style structs for Python"
+url="https://github.com/andreax79/python-cstruct"
+arch=('any')
+license=('MIT')
+depends=('python')
+makedepends=('python' 'python2')
+source=('https://pypi.python.org/packages/source/c/cstruct/cstruct-1.0.tar.gz')
+md5sums=('b12c1f3718875cafd52bc9222bd21dd5')
+
+prepare() {
+ cp -r cstruct-${pkgver} python2-cstruct-${pkgver}
+}
+
+build() {
+ cd ${srcdir}/cstruct-${pkgver}
+ python setup.py build
+
+ cd ${srcdir}/python2-cstruct-${pkgver}
+ python2 setup.py build
+}
+
+package_python-cstruct() {
+ depends=('python')
+
+ cd cstruct-${pkgver}
+ python setup.py install -O1 --root="${pkgdir}"
+}
+
+package_python2-cstruct() {
+ depends=('python2')
+
+ cd python2-cstruct-${pkgver}
+ python2 setup.py install -O1 --root="${pkgdir}"
+}