summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Sexton2023-06-22 05:24:58 -0400
committerMatthew Sexton2023-06-22 05:24:58 -0400
commit09bd425da9e8d62a9645ea4bdc4cb350516fdac5 (patch)
tree812d1486fb614d05be865fe59fe1f6d422769552 /PKGBUILD
downloadaur-09bd425da9e8d62a9645ea4bdc4cb350516fdac5.tar.gz
Initial commit curl_cffi-0.5.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45ff3af0e0fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Matthew Sexton <matthew@Asylumtech.com>
+
+pkgname=python-curl-cffi
+_name=curl_cffi
+pkgver=0.5.6
+pkgrel=1
+pkgdesc="Python binding for curl-impersonate via CFFI"
+arch=('any')
+url="https://github.com/yifeikong/curl_cffi"
+license=('GPL3')
+depends=( 'python-requests' 'python-aiohttp' 'curl-impersonate-chrome')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('30eea55149bd66dbb11aa467e3b4e039085bfac38da7fb8ae694425d9b7061da')
+
+build() {
+ cd "${_name}-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${_name}-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}