summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2017-01-10 13:53:27 -0500
committerGuillaume Horel2017-01-10 13:53:27 -0500
commit80a1f3db8d5274ad5e4b6f295ab62cc657c200d5 (patch)
tree4c523a1778043c88886af06bd9872606752d9f3e /PKGBUILD
downloadaur-80a1f3db8d5274ad5e4b6f295ab62cc657c200d5.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4022c1baa34b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgbase=('python-cvxcanon')
+pkgname=('python-cvxcanon')
+_module='CVXcanon'
+pkgver='0.1.1'
+pkgrel=1
+pkgdesc="C++ library to convert high-level optimization problems into canonical form."
+url="https://github.com/cvxgrp/CVXcanon"
+depends=('python')
+makedepends=('python-setuptools'
+ 'swig'
+ 'eigen')
+license=('unknown')
+arch=('i686' 'x86_64')
+source=("https://github.com/cvxgrp/CVXcanon/archive/v${pkgver}.tar.gz")
+md5sums=('ea900f44c30596d96999aa61eab89f08')
+
+prepare() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ patch -p1 < ../../use_system_eigen.patch
+ rm -rf include
+}
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}