summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2021-08-12 03:29:08 -0400
committerGuillaume Horel2021-08-12 03:29:08 -0400
commit6198cc790bc7626a534ad681dabff223a959f68e (patch)
treefb062fe12fd16d16771a46071d0d47cf052cebbe /PKGBUILD
parentfafeba02cd985efc42e95fcbe60a07ee279869b7 (diff)
downloadaur-6198cc790bc7626a534ad681dabff223a959f68e.tar.gz
fix dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad3cfa54e83e..959d6ff5939a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,17 @@ pkgver='1.1.14'
pkgrel=1
pkgdesc="A domain-specific language for modeling convex optimization problems"
url="http://github.com/cvxgrp/cvxpy/"
-depends=('python-ecos'
+depends=(
+ 'python'
+ 'python-ecos'
'python-fastcache'
'python-multiprocess'
'python-numpy'
'python-scipy'
'python-toolz')
makedepends=('python-setuptools')
-optdepends=('python-diffcp' 'python-osqp' 'python-scs')
-checkdepends=('python-pytest' 'python-osqp' 'python-scs')
+optdepends=('python-diffcp' 'python-cvxopt' 'python-osqp' 'python-scs')
+checkdepends=('python-pytest' 'python-cvxopt' 'python-osqp' 'python-scs')
license=('Apache')
arch=('any')
source=("$pkgname-$pkgver.tar.gz::https://github.com/cvxgrp/cvxpy/archive/v${pkgver}.tar.gz")