summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorClaudia Pellegrino2022-08-17 13:48:49 +0200
committerClaudia Pellegrino2022-08-17 13:52:31 +0200
commit4aed281839d94c5a91c1270f76588663a5345252 (patch)
tree2a08707dfd656d60970064b8a8c714eb9ff325e7 /PKGBUILD
parent26084c78246b2a4a1adcae0e4f80d77d19a4b9b6 (diff)
downloadaur-4aed281839d94c5a91c1270f76588663a5345252.tar.gz
python-cyclonedy-lib v2.7.1
Also use Poetry for building instead of the (unmaintained) `dephell`.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 735a0f7fd638..93b41e2a6171 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,39 @@
pkgname=python-cyclonedx-lib
_gitpkgname=cyclonedx-python-lib
-pkgver=1.1.0
+pkgver=2.7.1
pkgrel=1
pkgdesc='Library for producing CycloneDX SBOM (Software Bill of Materials) files'
arch=('any')
url='https://github.com/CycloneDX/cyclonedx-python-lib'
license=('Apache')
-depends=('python-packageurl' 'python-setuptools' 'python-importlib-metadata' 'python-toml' 'python-typing-extensions')
-makedepends=('python-dephell')
+depends=('python-packageurl' 'python-setuptools' 'python-importlib-metadata' 'python-sortedcontainers' 'python-toml')
+makedepends=('git' 'python-installer' 'python-poetry')
conflicts=('python-cyclonedx-lib-git')
options=('!strip')
source=("${_gitpkgname}-${pkgver}.tar.gz::https://github.com/CycloneDX/cyclonedx-python-lib/archive/refs/tags/v${pkgver}.tar.gz")
-sha512sums=('cc1e0968974ba4f5fa10094e781507b64725aa357b2c3b266bc4351bbc0c107531f52c24678f4abed82156bccd4cc6b91b239793312db015c353e3e3baf3f6f9')
+sha512sums=('ffdc136049d351b719fc49187d531a5595cc62744f41277bcba16e342aa872321ecf0c78ff7aa3a105eaf4b24d49ac31ffd3d5db64c2a5b795264f60776ebe49')
prepare() {
cd "${srcdir}/${_gitpkgname}-${pkgver}"
- dephell deps convert --from pyproject.toml --to setup.py
+ rm -rf dist # https://github.com/python-poetry/poetry/issues/1329
+
+ # Temporary workaround in order to prevent poetry from building an
+ # empty wheel. Remove this workaround as soon as the upstream fix
+ # lands in the community/python-poetry package.
+ #
+ # See also: https://github.com/python-poetry/poetry/issues/5547
+ git init
}
build() {
cd "${srcdir}/${_gitpkgname}-${pkgver}"
- python setup.py build
+ poetry build --format wheel
}
package() {
cd "${srcdir}/${_gitpkgname}-${pkgver}"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -I -X pycache_prefix=pycache -m installer --destdir="${pkgdir}" dist/*.whl
+ rm -rf pycache
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}