summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgilcu32024-11-13 14:05:10 +0100
committergilcu32024-11-13 14:05:10 +0100
commita42856b6a06672ec435237423dfdb2113f5d877b (patch)
tree4356db653e977c05c882f9afd35fc31e454d8cb8 /PKGBUILD
parentfe5e0797b86346b3d1d6cec80f9aaeda4db682b9 (diff)
downloadaur-a42856b6a06672ec435237423dfdb2113f5d877b.tar.gz
upgpkg: python-daemon 3.1.0-1
upstream release upd
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 14 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6b98a330e506..5a7833f1b695 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,37 @@
-# Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Maintainer: gilcu3
+# Previous Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
# Contributor: Anatol Pomozov
# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
pkgname=python-daemon
-pkgver=3.0.1
+pkgver=3.1.0
pkgrel=1
pkgdesc='Library to implement a well-behaved Unix daemon process'
arch=('any')
-url='https://pypi.python.org/pypi/python-daemon'
+url='https://pagure.io/python-daemon/'
license=('Apache')
depends=('python' 'python-lockfile' 'python-setuptools')
-makedepends=('python-build' 'python-docutils' 'python-installer' 'python-wheel')
-checkdepends=('python-testscenarios' 'python-testtools')
-source=(https://files.pythonhosted.org/packages/source/p/$pkgname/$pkgname-$pkgver.tar.gz
- 3bbc4696.patch)
-sha256sums=('6c57452372f7eaff40934a1c03ad1826bf5e793558e87fef49131e6464b4dae5'
- 'a65396fd70560e81ac2ccf4d016e9ea3ced6e7b4b14694bb4f30228d6fd07b49')
-b2sums=('5e695e20814ebb19fba2d8040abf15ba0c43c08700638d8f6dfb4a046cd1018f4da2a2ee0eb7f7333bc3b4bbbc18a4d68b799fe56f8da0d2ec4371e3307e5b6a'
- 'f8a7b626bab48b2dda8266f847d823b5dddeea8be18b2a0a7fa5d073f817a6d594286fa870fff7ad7d4f62fceafcdf5e7dd45a95c8e370bab207fe5d1ef6eb0c')
+makedepends=('python-build' 'python-docutils' 'python-installer' 'python-wheel' 'python-changelog-chug')
+checkdepends=('python-testscenarios' 'python-testtools' 'python-coverage')
+source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname//-/_}/${pkgname//-/_}-$pkgver.tar.gz)
+sha256sums=('fdb621d7e5f46e74b4de1ad6b0fff6e69cd91b4f219de1476190ebdd0f4781df')
-prepare() {
- cd $pkgname-$pkgver
-
- patch -p1 -i ../3bbc4696.patch # Fix build
-}
+# prepare() {
+# cd ${pkgname//-/_}-$pkgver
+# }
build() {
- cd $pkgname-$pkgver
+ cd ${pkgname//-/_}-$pkgver
python -m build --wheel --no-isolation
}
check() {
- cd $pkgname-$pkgver
+ cd ${pkgname//-/_}-$pkgver
python -m unittest discover -v
}
package_python-daemon() {
- cd $pkgname-$pkgver
+ cd ${pkgname//-/_}-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE.ASF-2 "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE.ASF-2