summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorneodarz2020-06-04 17:45:34 +0200
committerneodarz2020-06-04 17:45:34 +0200
commite9f6eb28146f507a6e6beecef59355f1545ee46d (patch)
tree5cfe96c87131adba7a39760530da9ea7964b74da /PKGBUILD
downloadaur-e9f6eb28146f507a6e6beecef59355f1545ee46d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d413ffa5a5bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: neodarz <neodarz at neodarz dot net>
+
+_pkgname=darglint
+pkgname=python-$_pkgname
+
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="A python documentation linter which checks that the docstring description matches the definition."
+
+url='https://github.com/terrencepreilly/darglint'
+arch=('any')
+license=('MIT')
+
+depends=('python')
+
+source=("https://github.com/terrencepreilly/$_pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('b287805e6296320de4d77f026a7011bf33a4d1da9162f0ffbdc150d9f526e4526228c640455c465706c0aa43b4d64db76bb3916add36d82e226d2df9b054496e')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+