summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-02-07 18:29:18 -0600
committerLuis Martinez2022-02-07 18:29:18 -0600
commit1ad005261d03ae096f0635fed90f12243863f94a (patch)
tree40e26c036a17197ef5beea709e04fd000953de2d /PKGBUILD
parent46e8b162fc4d81f6011950787ea50db503c9e54e (diff)
downloadaur-1ad005261d03ae096f0635fed90f12243863f94a.tar.gz
replace setuptools with python-build/install
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0df4c23a9c61..cfe0d5c9209f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,21 @@
pkgname=python-dataproperty
pkgver=0.54.2
-pkgrel=2
+pkgrel=3
pkgdesc='Extract properties from data'
arch=('any')
url='https://github.com/thombashi/DataProperty'
license=('MIT')
depends=('python-mbstrdecoder' 'python-typepy')
-makedepends=('python-setuptools' 'python-docutils' 'python-pygments')
+makedepends=(
+ 'python-setuptools'
+ 'python-build'
+ 'python-install'
+ 'python-wheel'
+ 'python-docutils'
+ 'python-pygments')
checkdepends=(
'python-pytest'
- 'python-pytest-runner'
'python-termcolor'
'python-dateutil'
'python-pytz')
@@ -25,18 +30,19 @@ validpgpkeys=('BCF9203E5E80B5607EAE6FDD98CDA9A5F0BFC367')
build() {
cd "DataProperty-$pkgver"
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
rst2man README.rst "$pkgname.7"
}
check() {
cd "DataProperty-$pkgver"
- python setup.py pytest
+ PYTHONPATH=./ pytest -x --disable-warnings
}
package() {
+ export PYTHONHASHSEED=0
cd "DataProperty-$pkgver"
- PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
install -Dm644 "$pkgname.7" -t "$pkgdir/usr/share/man/man7/"
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}