summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Dewender2014-06-11 11:47:08 +0200
committerJohannes Dewender2014-06-11 11:47:08 +0200
commitca81edf31a4da86d019338a8d752b37596846013 (patch)
treec1e6680be48186d3fad465f557af1363c4674ad7 /PKGBUILD
downloadaur-ca81edf31a4da86d019338a8d752b37596846013.tar.gz
python-debian: created as 0.1.21-nmu2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c164b759d6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Johannes Dewender arch at JonnyJD dot net
+pkgname=python-debian
+_python=python
+pkgver=0.1.21_nmu2
+_pkgver=0.1.21-nmu2
+pkgrel=1
+pkgdesc="Python modules to work with Debian-related data formats"
+arch=('any')
+url="http://packages.debian.org/sid/python-debian"
+license=('GPL')
+depends=($_python $_python-chardet $_python-six)
+optdepends=("$_python-apt: interface to libapt-pkg")
+makedepends=()
+conflicts=()
+options=(!emptydirs)
+source=(http://pypi.python.org/packages/source/p/$pkgname/$pkgname-$_pkgver.tar.gz)
+md5sums=('09c0b6ce10bf473c54fff9e6c62fe1d6')
+
+build() {
+ cd "$srcdir/$pkgname-$_pkgver"
+ $_python setup.py build
+}
+package() {
+ cd "$srcdir/$pkgname-$_pkgver"
+ $_python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: