summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Oelmueller2021-01-02 11:27:36 +0100
committerChris Oelmueller2021-01-02 11:28:27 +0100
commite14ea665511f1b0a25e716c6abfe219690f0d77e (patch)
tree42eaa7162c9c430c51499f463137df00291687a8 /PKGBUILD
parentee3350aaaeebee6e8f346c18602366e51b8c51de (diff)
downloadaur-e14ea665511f1b0a25e716c6abfe219690f0d77e.tar.gz
python-deepdiff v5.2.1-1
drops py3.5 compat
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8eeaa8fc8136..0f460e7a664e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Chris Oelmueller <chris.oelmueller@gmail.com>
_pythonname=deepdiff
pkgname=python-${_pythonname}
-pkgver=5.0.2
+pkgver=5.2.1
pkgrel=1
pkgdesc="Deep Difference of dictionaries, iterables, strings and other objects. It will recursively look for all the changes."
arch=('any')
url="https://github.com/seperman/${_pythonname}"
license=('MIT')
-depends=('python' 'python-jsonpickle' 'python-ordered-set')
+# The last version of DeepDiff to work on Python 3.5 was DeepDiff 5.0.2
+depends=('python>=3.6' 'python-jsonpickle' 'python-ordered-set')
makedepends=('python-setuptools')
optdepends=('python-mmh3: murmurhash3 for faster hashing')
source=("https://pypi.io/packages/source/d/${_pythonname}/${_pythonname}-${pkgver}.tar.gz")
-sha1sums=('1d1484d74f22a43b32db7f6806509d7dd96bb8c7')
-sha256sums=('e2b74af4da0ef9cd338bb6e8c97242c1ec9d81fcb28298d7bb24acdc19ea79d7')
-sha512sums=('2211903eefc49cdd4d926c2e3a83fe1e6d7891404a35e10e73be9dc7801d2b6d83f30630e501658c67450ed014227c5d13c3b19489fbb34b3afa836369d5f8f5')
+sha1sums=('231384bb8a94ad8146cc06d78176c3faa6a1866c')
+sha256sums=('2e368943dc257f6fa93d9ce4537dbcd4fea65098208a0f49f675cf40132c1a89')
+sha512sums=('6a26ca89f71ebacf4e706ea77500fcc9185da123e9cb22b409e16ec8d56fe40654c076ccf64421501fd7b9f70101cbc0ce69af81d44356ca693b1802851bfcdc')
build() {
cd "$srcdir/${_pythonname}-${pkgver}"