summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlphaJack2021-10-04 10:05:00 +0200
committerAlphaJack2021-10-04 10:05:00 +0200
commit38d2c1f235503f231c78d190c4c8b8393e77550f (patch)
tree855341a40f0f3715f2c4a9b0950b38bc97363ddf /PKGBUILD
downloadaur-38d2c1f235503f231c78d190c4c8b8393e77550f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17e5712c18ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="python-degiro-connector"
+pkgver=2.0.2
+pkgrel=1
+pkgdesc="Yet another library to access Degiro's API"
+url="https://github.com/Chavithra/degiro-connector"
+license=("BSD-3")
+arch=("any")
+provides=("degiro-connector" "python-degiro-connector")
+# not adding "python-orjson" because it is not compatible with ARM architectures yet
+depends=("python-grpcio" "python-onetimepass" "python-pandas" "python-protobuf" "python-requests" "python-wrapt")
+makedepends=("python-dephell" "python-setuptools")
+source=("https://github.com/Chavithra/degiro-connector/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('cfdb5ee556cde363ed69051c1ab834d071087fc36d7b27bd46f6daccb671a659')
+
+prepare(){
+ cd "degiro-connector-$pkgver"
+ # use plain json because orjson is not compatible with ARM architectures yet
+ find . -type f -not -path "*/.git/*" -exec sed -i {} -e "s/import orjson as json/import json/g" -e "s/'orjson',/#'orjson',/g" \;
+ dephell deps convert --from pyproject.toml --to setup.py
+}
+
+build(){
+ cd "degiro-connector-$pkgver"
+ python setup.py build
+}
+
+package(){
+ cd "degiro-connector-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}