summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Botting2017-04-12 16:53:15 +1000
committerAndy Botting2017-04-12 16:53:15 +1000
commita2fc21192cf6b0c0760e589cdfe7e0f931d62a04 (patch)
tree40e7068166c2b9e29a4d841659ebefcf30f145fb /PKGBUILD
parentd3ff0795c030df29a00d03a0b7ad9fbeaccb69f4 (diff)
downloadaur-a2fc21192cf6b0c0760e589cdfe7e0f931d62a04.tar.gz
Update to v2.6.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 35 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf485ad5249f..eee05009126c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,61 @@
pkgname=('python-designateclient' 'python2-designateclient')
pkgver='2.6.0'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Python client library for Designate'
arch=('any')
-url='http://docs.openstack.org/developer/python-designateclient'
+url="https://docs.openstack.org/developer/${pkgname}"
license=('Apache')
-makedepends=('python-setuptools' 'python2-setuptools')
-source=("git+https://git.openstack.org/openstack/python-designateclient#tag=$pkgver")
+makedepends=('git' 'python-setuptools' 'python2-setuptools')
+checkdepends=('python-cliff' 'python2-cliff'
+ 'python-debtcollector' 'python2-debtcollector'
+ 'python-jsonschema' 'python2-jsonschema'
+ 'python-osc-lib' 'python2-osc-lib'
+ 'python-oslo-utils' 'python2-oslo-utils'
+ 'python-keystoneauth1' 'python2-keystoneauth1'
+ 'python-pbr' 'python2-pbr'
+ 'python-requests' 'python2-requests'
+ 'python-six' 'python2-six'
+ 'python-stevedore' 'python2-stevedore'
+ 'python-oslo-config' 'python2-oslo-config'
+ 'python-oslotest' 'python2-oslotest'
+ 'python-requests-mock' 'python2-requests-mock'
+ 'python-subunit' 'python2-subunit')
+source=("git+https://git.openstack.org/openstack/${pkgname}#tag=$pkgver")
md5sums=('SKIP')
prepare() {
- cp -a python-designateclient{,-py2}
+ cp -a "${srcdir}/${pkgname}"{,-py2}
}
build() {
- cd "$srcdir"/python-designateclient
+ cd "${srcdir}/${pkgname}"
python setup.py build
- cd "$srcdir"/python-designateclient-py2
+ cd "${srcdir}/${pkgname}-py2"
python2 setup.py build
}
+check() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py testr
+
+ cd "${srcdir}/${pkgname}-py2"
+ PYTHON=python2 python2 setup.py testr
+}
+
package_python-designateclient() {
- depends=('python-cliff' 'python-debtcollector' 'python-jsonschema' 'python-osc-lib'
- 'python-oslo-utils' 'python-keystoneauth1' 'python-pbr' 'python-requests'
- 'python-six' 'python-stevedore')
+ depends=('python-cliff' 'python-debtcollector' 'python-jsonschema'
+ 'python-osc-lib' 'python-oslo-utils' 'python-keystoneauth1'
+ 'python-pbr' 'python-requests' 'python-six' 'python-stevedore')
cd "${srcdir}/${pkgname}"
python setup.py install --root="${pkgdir}" --optimize=1
}
package_python2-designateclient() {
- depends=('python2-cliff' 'python2-debtcollector' 'python2-jsonschema' 'python2-osc-lib'
- 'python2-oslo-utils' 'python2-keystoneauth1' 'python2-pbr' 'python2-requests'
- 'python2-six' 'python2-stevedore')
+ depends=('python2-cliff' 'python2-debtcollector' 'python2-jsonschema'
+ 'python2-osc-lib' 'python2-oslo-utils' 'python2-keystoneauth1'
+ 'python2-pbr' 'python2-requests' 'python2-six' 'python2-stevedore')
cd "${srcdir}/python-designateclient-py2"
python2 setup.py install --root="${pkgdir}" --optimize=1
mv "${pkgdir}"/usr/bin/designate{,2}