summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPau Ruiz i Safont2018-04-24 12:39:01 +0100
committerPau Ruiz i Safont2018-04-24 12:43:13 +0100
commit5fd028fdf4619ec8b155a3d553973f60b10d10b6 (patch)
tree4181c0e9325f8de3a0d044a67e0d5527aefba61a /PKGBUILD
downloadaur-5fd028fdf4619ec8b155a3d553973f60b10d10b6.tar.gz
0.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58db1f82121e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Pau Ruiz Safont <unduthegun at gmail dot com>
+pkgname=python-detox
+_realname=detox
+pkgver=0.12
+pkgrel=1
+pkgdesc="distributing activities of the tox tool"
+url="https://github.com/tox-dev/detox"
+depends=('python' 'python-tox>=2.0.0' 'python-py>=1.4.27' 'python-eventlet>=0.15.0')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_realname::1}/$_realname/$_realname-$pkgver.tar.gz")
+md5sums=('da59e8e175102eacc9559da9b6ed7fad')
+
+build() {
+ cd $srcdir/$_realname-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/$_realname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+ mv "${pkgdir}/usr/bin/detox" "${pkgdir}/usr/bin/detox-python"
+ }