summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiacomo Longo2018-08-26 00:14:02 +0200
committerGiacomo Longo2018-08-26 00:14:02 +0200
commit02112c1993c03f0449e59bbdd9953ed32a3dd5cd (patch)
tree2e5b838c8f16b1f547725615f015fc7b083e1d06 /PKGBUILD
downloadaur-02112c1993c03f0449e59bbdd9953ed32a3dd5cd.tar.gz
python-dictdiffer - Version 0.7.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1799f233239f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Giacomo Longo <gabibbo97@gmail.com>
+pkgname=python-dictdiffer
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="Dictdiffer is a library that helps you to diff and patch dictionaries"
+url="https://github.com/openshift/openshift-restclient-python"
+license=('APACHE')
+_name=${pkgname#python-}
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+arch=('any')
+makedepends=('python-setuptools')
+depends=('python')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+md5sums=('e58fbec47e54ee4450bc768b08cb1ae4')