summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorg Schlisio2017-07-03 09:26:56 +0200
committerGeorg Schlisio2017-07-03 09:26:56 +0200
commit3f8e9b86c466d8d10952d5dd3db3fe1f7d181ddc (patch)
tree38e6b7ea2ac20a7b3f61cf2324b426cf835ee028 /PKGBUILD
parent6a59b187af9c495d0019a71091b6951a832488ae (diff)
downloadaur-3f8e9b86c466d8d10952d5dd3db3fe1f7d181ddc.tar.gz
makedepends in the right place, version bump omitted
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f4e54587a7b..4c2e5cba0475 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,7 @@ pkgrel=4
pkgdesc='Serialize all of python (almost)'
arch=('any')
url='http://pypi.python.org/pypi/dill/'
+makedepends=('python-setuptools' 'python2-setuptools')
license=('BSD')
source=("https://github.com/uqfoundation/dill/releases/download/$pkgver/dill-$pkgver.tgz" "python2-dill.install")
md5sums=('eff3385ff87c3de142ce502b38fb928a'
@@ -20,7 +21,6 @@ build() {
package_python-dill() {
depends=('python')
- makedepends=('python-setuptools')
cd "$srcdir/dill-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
@@ -28,7 +28,6 @@ package_python-dill() {
package_python2-dill() {
depends=('python2')
- makedepends=('python2-setuptools')
install=python2-dill.install
cd "$srcdir/dill-$pkgver"
find . -name "*.py" -exec sed -i 's#/usr/bin/env python#/usr/bin/env python2#' {} \;