summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgeorg2017-06-25 18:27:29 +0200
committergeorg2017-06-25 18:27:29 +0200
commit6a59b187af9c495d0019a71091b6951a832488ae (patch)
treeed502e62baa836c2e9bdf173d2488401c26e68c4 /PKGBUILD
parentf906244b8298f48d9afba8c10b0e1169fcbd8ecf (diff)
downloadaur-6a59b187af9c495d0019a71091b6951a832488ae.tar.gz
makedeps fixed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4b6417862e4..4f4e54587a7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=("python-dill" "python2-dill")
pkgbase=python-dill
pkgver=0.2.6
-pkgrel=3
+pkgrel=4
pkgdesc='Serialize all of python (almost)'
arch=('any')
url='http://pypi.python.org/pypi/dill/'
@@ -20,6 +20,7 @@ build() {
package_python-dill() {
depends=('python')
+ makedepends=('python-setuptools')
cd "$srcdir/dill-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
@@ -27,6 +28,7 @@ package_python-dill() {
package_python2-dill() {
depends=('python2')
+ makedepends=('python2-setuptools')
install=python2-dill.install
cd "$srcdir/dill-$pkgver"
find . -name "*.py" -exec sed -i 's#/usr/bin/env python#/usr/bin/env python2#' {} \;