summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmos Onn2019-09-14 01:44:02 +0200
committerAmos Onn2019-09-14 01:44:02 +0200
commit21a54faa4faed8b689b32ec9ccdd5c97a8e86220 (patch)
treeebae52812ba3de54cd7f5a9dff9a5d0699b91fbd /PKGBUILD
parentc024789ff5f05492fefa4090527396aee516f315 (diff)
downloadaur-21a54faa4faed8b689b32ec9ccdd5c97a8e86220.tar.gz
Bumped to 2.4.0 (dropped python2 split-package)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 19 insertions, 47 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1069e346cb50..f1598cc9245f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,33 @@
# Maintainer: Amos Onn <amosonn at gmail dot com>
-pkgbase=python-distributed
-pkgname=('python-distributed' 'python2-distributed')
+pkgname=python-distributed
_pkgname=distributed
-pkgver=1.27.1
+pkgver=2.4.0
pkgrel=1
pkgdesc="A python library for distributed computation."
arch=('any')
+depends=('python>=3.5' 'python-click>=6.6' 'python-cloudpickle>=0.2.2'
+'python-dask>=2' 'python-msgpack' 'python-psutil>=5.0'
+'python-sortedcontainers>2.0.1' 'python-tblib' 'python-toolz>=0.7.4'
+'python-tornado>=5' 'python-zict>=0.1.3' 'python-yaml')
+optdepends=(
+# dev-requirements.txt
+'python-joblib>=0.10.2' 'python-pandas>=0.19.2' 'python-numpy>=1.11.0'
+'python-bokeh>=0.12.3' 'python-requests>=2.12.4' 'python-pyzmq>=16.0.2'
+'ipython>=5.0.0' 'python-jupyter_client>=4.4.0' 'python-ipykernel>=4.5.2'
+'python-pytest>=3.0.5' 'python-prometheus_client>=0.6.0'
+'python-jupyter-server-proxy>=1.1.0'
+# pytest.importorskip
+'python-keras' 'python-lz4' 'python-netcdf4' 'python-h5py'
+'python-paramiko' 'python-ipywidgets' # crick, hdfs-3
+)
url="http://distributed.readthedocs.org/en/stable/"
license=('BSD-3-clause')
source=(https://codeload.github.com/dask/distributed/tar.gz/$pkgver)
-sha256sums=('94209abe84bbcd02dab633fdb5bee2df5995a4a6353623c18c7ac1a68239c2f7')
+sha256sums=('2e1e37713df8dd89aac644d0cbac0aa73aead6d91cd7b6f5a55706f32789c051')
-prepare() {
- cp -a $_pkgname-$pkgver{,-py2}
-}
-
-package_python-distributed() {
- depends=('python>=3.5' 'python-click>=6.6' 'python-cloudpickle>=0.2.2'
- 'python-dask>=0.18.0' 'python-msgpack' 'python-psutil>=5.0' 'python-six'
- 'python-sortedcontainers>2.0.1' 'python-tblib' 'python-toolz>=0.7.4'
- 'python-tornado>=5' 'python-zict>=0.1.3' 'python-yaml')
- # For supporting older versions of python 3:
- # singledispatch; python_version < '3.4'
- optdepends=(
- # dev-requirements.txt
- 'python-joblib>=0.10.2' 'python-mock>=2.0.0' 'python-pandas>=0.19.2'
- 'python-numpy>=1.11.0' 'python-bokeh>=0.12.3' 'python-requests>=2.12.4'
- 'python-pyzmq>=16.0.2' 'ipython>=5.0.0' 'python-jupyter_client>=4.4.0'
- 'python-ipykernel>=4.5.2' 'python-pytest>=3.0.5'
- # pytest.importorskip
- 'python-keras' 'python-lz4' 'python-netcdf4' 'python-h5py'
- 'python-paramiko' 'python-ipywidgets' # crick, hdfs-3
- )
+package() {
cd $srcdir/$_pkgname-$pkgver
python setup.py install --root=$pkgdir || return 1
install -d $pkgdir/usr/share/licenses/$pkgname
install LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/COPYING
}
-
-package_python2-distributed() {
- depends=('python2' 'python2-click>=6.6' 'python2-cloudpickle>=0.2.2'
- 'python2-dask>=0.18.0' 'python2-msgpack' 'python2-psutil>=5.0' 'python2-six'
- 'python2-sortedcontainers>2.0.1' 'python2-tblib' 'python2-toolz>=0.7.4'
- 'python2-tornado>=5' 'python2-zict>=0.1.3' 'python2-yaml'
- 'python2-futures' 'python2-singledispatch')
- optdepends=(
- # dev-requirements.txt
- 'python2-joblib>=0.10.2' 'python2-mock>=2.0.0' 'python2-pandas>=0.19.2'
- 'python2-numpy>=1.11.0' 'python2-bokeh>=0.12.3' 'python2-requests>=2.12.4'
- 'python2-pyzmq>=16.0.2' 'ipython2>=5.0.0' 'python2-jupyter_client>=4.4.0'
- 'python2-ipykernel>=4.5.2' 'python2-pytest>=3.0.5'
- # pytest.importorskip
- 'python2-keras' 'python2-lz4' 'python2-netcdf4' 'python2-h5py'
- 'python2-paramiko' 'python2-ipywidgets' # crick, hdfs-3
- )
- cd $srcdir/$_pkgname-$pkgver-py2
- python2 setup.py install --root=$pkgdir || return 1
- install -d $pkgdir/usr/share/licenses/$pkgname
- install LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/COPYING
-}