summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmos Onn2016-04-03 17:28:47 +0300
committerAmos Onn2016-04-03 17:28:47 +0300
commit2a80b54d0c78a335dda5069b5cf2f9bc6d8ff231 (patch)
tree0d31a17c1a21e3c289c45e7d1250db02dfd90e2a /PKGBUILD
downloadaur-2a80b54d0c78a335dda5069b5cf2f9bc6d8ff231.tar.gz
First commit; 1.9.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dafe20fd2d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=python-distributed
+pkgver=1.9.1
+pkgrel=1
+pkgdesc="A python library for distributed computation."
+arch=('any')
+url="http://distributed.readthedocs.org/en/stable/"
+license=('Other')
+depends=('python>=3.5' 'python-tornado' 'python-toolz' 'python-cloudpickle'
+ 'python-dask' 'python-click' 'python-locket' 'python-boto3'
+ 'python-six' 'python-tblib' 'python-msgpack')
+optdepends=('python-paramiko' 'python-pandas' 'python-ipywidgets')
+source=(https://github.com/dask/distributed/archive/$pkgver.tar.gz)
+sha256sums=('270189d60f35547cf6c0366871989e5ecd3f585f73af4aac07925d8a43385dce')
+
+package() {
+ cd $srcdir/distributed-$pkgver
+ python setup.py install --root=$pkgdir || return 1
+ install -d $pkgdir/usr/share/licenses/$pkgname
+ install LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/COPYING
+}