summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmos Onn2017-04-10 17:12:07 +0200
committerAmos Onn2017-04-10 17:12:07 +0200
commit2b1b8e5a1549730ca2ce677cb7ff9490abd9c63b (patch)
tree6fe98af71f95333605ad4c3b3542724c82650af4 /PKGBUILD
parent2a80b54d0c78a335dda5069b5cf2f9bc6d8ff231 (diff)
downloadaur-2b1b8e5a1549730ca2ce677cb7ff9490abd9c63b.tar.gz
Bumped to 1.16.1 (added three AUR packages for deps).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 22 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1dafe20fd2d2..4be28787dfff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,30 @@
+# Maintainer: Amos Onn <amosonn at gmail dot com>
pkgname=python-distributed
-pkgver=1.9.1
+pkgver=1.16.1
pkgrel=1
pkgdesc="A python library for distributed computation."
arch=('any')
url="http://distributed.readthedocs.org/en/stable/"
-license=('Other')
-depends=('python>=3.5' 'python-tornado' 'python-toolz' 'python-cloudpickle'
- 'python-dask' 'python-click' 'python-locket' 'python-boto3'
- 'python-six' 'python-tblib' 'python-msgpack')
-optdepends=('python-paramiko' 'python-pandas' 'python-ipywidgets')
-source=(https://github.com/dask/distributed/archive/$pkgver.tar.gz)
-sha256sums=('270189d60f35547cf6c0366871989e5ecd3f585f73af4aac07925d8a43385dce')
+license=('BSD-3-clause')
+depends=('python>=3.5' 'python-tornado>=4.2' 'python-toolz>=0.7.4'
+ 'python-cloudpickle>=0.2.2' 'python-dask>=0.14.0' 'python-click>=6.6'
+ 'python-psutil' 'python-zict>=0.1.1' 'python-sortedcollections' 'python-six'
+ 'python-tblib' 'python-msgpack')
+# For supporting other versions of python:
+# futures; python_version < '3.0'
+# singledispatch; python_version < '3.4'
+optdepends=(
+ # dev-requirements.txt
+ 'python-joblib>=0.10.2' 'python-mock>=2.0.0' 'python-pandas>=0.19.2'
+ 'python-numpy>=1.11.0' 'python-bokeh>=0.12.3' 'python-requests>=2.12.4'
+ 'python-pyzmq>=16.0.2' 'ipython>=5.0.0' 'python-jupyter_client>=4.4.0'
+ 'python-ipykernel>=4.5.2' 'python-pytest>=3.0.5'
+ # pytest.importorskip
+ 'python-keras' 'python-lz4' 'python-netcdf4' 'python-h5py' 'python-paramiko'
+ 'python-ipywidgets' # crick, hdfs-3
+)
+source=(https://codeload.github.com/dask/distributed/tar.gz/$pkgver)
+sha256sums=('bc67f823621bf9d5e235d5e8db5772476dd38208c815172125ceeb6b2347cfac')
package() {
cd $srcdir/distributed-$pkgver