summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsti2d2018-02-18 08:24:06 +0100
committersti2d2018-02-18 08:24:06 +0100
commite78ee3c2d49e94506b011f76098b74669e0aa336 (patch)
treebd71391fc2ea7d54a5c202320af9c7fc5d3aadcf /PKGBUILD
downloadaur-e78ee3c2d49e94506b011f76098b74669e0aa336.tar.gz
Version bump from python-asgi-redis, project renaming
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e737a9fa810
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Razer <razer[AT]neuf[DOT]fr>
+
+pkgname=python-django-channels-redis
+_pypi_pkgname=channels_redis
+pkgver=2.0.3
+pkgrel=0
+pkgdesc="Redis-backed ASGI channel layer implementation"
+arch=(any)
+url=" http://github.com/django/channels_redis/"
+license=('BSD')
+makedepends=('python-setuptools')
+depends=('python' 'python-django-channels' 'python-aioredis' 'python-msgpack' 'python-asgiref' 'python-async-timeout')
+source=("https://pypi.io/packages/source/c/${_pypi_pkgname}/${_pypi_pkgname}-${pkgver}.tar.gz")
+md5sums=('1c7556da9f30a2adb60d46ef723cc327')
+
+build() {
+ cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
+ python setup.py install --root=${pkgdir} --optimize=1 || return 1
+}