summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Hanna2016-02-16 01:51:51 +0100
committerSimon Hanna2016-02-16 01:51:51 +0100
commit1e4b69de2e0d91c1f87a12f135e33f0619083b70 (patch)
treefd9500c1d40b1a0e14695e18240d8a631c2193eb /PKGBUILD
parent2ab3f3f5107bbc1293f175bd965a3c69185b4a24 (diff)
downloadaur-1e4b69de2e0d91c1f87a12f135e33f0619083b70.tar.gz
upgpkg: python-django-crispy-forms 1.6.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 3 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a866c99b694..9d2700ade1c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Simon Hanna <simon dot hanna AT serve-me DOT info>
pkgname=('python-django-crispy-forms' 'python2-django-crispy-forms')
-pkgver=1.5.2
+pkgver=1.6.0
pkgrel=1
pkgdesc="Provides DRY django forms"
arch=(any)
@@ -9,29 +9,14 @@ url="https://github.com/maraujop/django-crispy-forms"
license=('MIT')
options=(!emptydirs)
source=("https://github.com/maraujop/django-crispy-forms/archive/${pkgver}.tar.gz")
-sha256sums=('a790f85b917c93f3895cda6c36716e6ae749104ea9b44871400d94b82f879e0e')
+sha256sums=('dc20b4ce41cc352917a32042f763f7d450deee4b981521530ad8b71c8d13b78e')
makedepends=('python-setuptools' 'python2-setuptools')
checkdepends=('python-tox')
-prepare() {
- cp -a django-crispy-forms-$pkgver{,-py2}
-}
-
-build() {
- cd "$srcdir/django-crispy-forms-$pkgver"
- python setup.py build
-
- cd "$srcdir/django-crispy-forms-$pkgver-py2"
- python2 setup.py build
-}
-
check() {
cd "$srcdir/django-crispy-forms-$pkgver"
- tox -e py35-django18
-
- cd "$srcdir/django-crispy-forms-$pkgver-py2"
- tox -e py27-django18
+ tox -e py35-django19 py27-django19
}
package_python-django-crispy-forms() {