summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorŁukasz Pożarlik2023-07-15 21:42:37 +0200
committerŁukasz Pożarlik2023-07-15 21:42:37 +0200
commit885b77aebe1e795138202a554e15bcf2a5575173 (patch)
tree6b1026cc2f44f1e789c0dbba666530bbe8bcd3bf /PKGBUILD
parent77925e8612b90332ffd4f3972f76666a81b2abcd (diff)
downloadaur-885b77aebe1e795138202a554e15bcf2a5575173.tar.gz
Drop python2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 5 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2205427113ef..d321b877ac8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,28 @@
# Maintainer: Łukasz Pożarlik <lpozarlik@gmail.com>
-pkgname=('python-django-location-field' 'python2-django-location-field')
+pkgname=('python-django-location-field')
pkgdesc="Let users pick locations using a map widget and store its latitude and longitude"
pkgver=2.1.0
-pkgrel=4
+pkgrel=5
url="https://github.com/caioariede/django-location-field"
license=('MIT')
arch=('any')
makedepends=('python'
- 'python-setuptools'
- 'python2'
- 'python2-setuptools')
+ 'python-setuptools')
+depends=('python-django')
source=("https://files.pythonhosted.org/packages/source/d/django-location-field/django-location-field-${pkgver}.tar.gz")
sha256sums=('fbde6115814fb0b071b8026d5b0c906efca20a79536110f7dc33d1e505c85106')
build() {
- cp -r ${srcdir}/django-location-field-${pkgver} ${srcdir}/django-location-field-${pkgver}-py2
-
cd ${srcdir}/django-location-field-${pkgver}
python setup.py build
-
- cd ${srcdir}/django-location-field-${pkgver}-py2
- python2 setup.py build
}
package_python-django-location-field() {
- depends=('python-django')
cd ${srcdir}/django-location-field-${pkgver}
python setup.py install --prefix=/usr --root=${pkgdir}
install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
- rm -rf "$pkgdir/usr/lib/python3.10/site-packages/tests"
-}
-
-package_python2-django-location-field() {
- depends=('python2-django')
- cd ${srcdir}/django-location-field-${pkgver}-py2
- python2 setup.py install --prefix=/usr --root=${pkgdir}
- install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
- rm -rf "$pkgdir/usr/lib/python3.10/site-packages/tests"
+ rm -rf "$pkgdir/usr/lib/python3.11/site-packages/tests"
}
# vim:set ts=2 sw=2 et:
-