summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlphaJack2021-06-02 22:56:05 +0200
committerAlphaJack2021-06-02 22:56:05 +0200
commit83b67ac9d9ac39160e6a3c5ef872d85a4cadd27e (patch)
treebdfc637a06edd38de10e68b8416c7ddc93d26b32 /PKGBUILD
downloadaur-83b67ac9d9ac39160e6a3c5ef872d85a4cadd27e.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cb1ac722750
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="python-django-recaptcha-git"
+pkgver=2.0.6.r7.gdc7cbfe
+pkgrel=1
+pkgdesc="Django reCAPTCHA form field/widget integration app"
+url="https://github.com/praekelt/django-recaptcha"
+license=("BSD3")
+arch=("any")
+provides=("python-django-recaptcha")
+depends=("mkdocs")
+makedepends=("python-setuptools" "python-wheel")
+source=("git+$url")
+sha256sums=("SKIP")
+
+pkgver(){
+ cd "django-recaptcha"
+ git describe --long --tags | sed "s/\([^-]*-g\)/r\1/;s/-/./g"
+}
+
+build(){
+ cd "django-recaptcha"
+ python setup.py build
+}
+
+package(){
+ cd "django-recaptcha"
+ python setup.py install --root="$pkgdir" --optimize=1
+}