summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrazer2016-12-27 07:27:37 +0100
committerrazer2016-12-27 07:27:37 +0100
commit5a18efa76b0ab6a6e0a671283e6488ef61615668 (patch)
tree511760df04890dc4f6aec5321190f034f6bef9bf /PKGBUILD
downloadaur-5a18efa76b0ab6a6e0a671283e6488ef61615668.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2f5371e5411
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Razer <razer@neuf.fr>
+
+pkgname=python-django-rest-auth
+_pypi_pkgname=django-rest-auth
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="Django-rest-auth provides a set of REST API endpoints for Authentication and Registration"
+arch=(any)
+url="https://github.com/Tivix/django-rest-auth/"
+license=('MIT')
+makedepends=('python-setuptools')
+depends=('python' 'python-django' 'python-django-rest-framework')
+source=("https://github.com/Tivix/django-rest-auth/archive/v${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
+ python setup.py install --root=${pkgdir} --optimize=1 || return 1
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+
+