summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlphaJack2021-06-02 23:18:59 +0200
committerAlphaJack2021-06-02 23:18:59 +0200
commite7c6ec8d4f39921f4f141c1810d3dd9178c51e93 (patch)
tree14aa01ac6ac6777b013b8cc9cfa7a853185380e5 /PKGBUILD
parentd137471c2758da89283e52fa597ab010b6dc1847 (diff)
downloadaur-e7c6ec8d4f39921f4f141c1810d3dd9178c51e93.tar.gz
Updated package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 15 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8813437b324..a8daea1f1fca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,19 @@
-#Maintainer: David McInnis <davidm@eagles.ewu.edu>
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+# Contributor: David McInnis <davidm@eagles.ewu.edu>
-pkgbase=('python-django-sortedm2m')
-pkgname=('python-django-sortedm2m')
-_module='django-sortedm2m'
-pkgver='1.1.1'
+pkgname="python-django-sortedm2m"
+pkgver=3.0.2
pkgrel=1
-pkgdesc="Drop-in replacement for django's many to many field with sorted relations."
-url="http://github.com/gregmuellegger/django-sortedm2m"
-depends=('python-django')
-makedepends=('python-setuptools')
-license=('BSD')
-arch=('any')
-source=("https://pypi.python.org/packages/source/d/django-sortedm2m/django-sortedm2m-${pkgver}.tar.gz")
-sha256sums=('d38d201da8593c94c8706f9ef30e3203bf0d352d6264abbb7babfbb112f86cb4')
+pkgdesc="A transparent sorted ManyToMany field for django"
+url="https://github.com/jazzband/django-sortedm2m"
+depends=("python-django")
+makedepends=("python-setuptools" "python-wheel")
+license=("BSD")
+arch=("any")
+source=("https://github.com/jazzband/django-sortedm2m/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=("f14b86ab4f610de42937c11058664b2f8e9b722ae42f0197c448125eb9895777")
-package() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
- install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+package(){
+ cd "django-sortedm2m-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
}