summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-12-18 21:26:12 +0100
committerJaroslav Lichtblau2014-12-18 21:26:12 +0100
commita934c5bc3ecfbb72c0d02e0c86f9511b108b3b93 (patch)
treec90442b1bacf27ce81e53e23fe2bc7cbe3b65070 /PKGBUILD
downloadaur-a934c5bc3ecfbb72c0d02e0c86f9511b108b3b93.tar.gz
python-django-taggit-0.12.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe0bdc547ed7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgbase=python-django-taggit
+pkgname=(python-django-taggit python2-django-taggit)
+_pkgname=django-taggit
+pkgver=0.12.1
+pkgrel=1
+pkgdesc="Simple tagging application for Django"
+arch=('any')
+url="http://github.com/alex/django-taggit/"
+license=('BSD')
+makedepends=('python2-django' 'python-django')
+source=(http://pypi.python.org/packages/source/d/$_pkgname/$_pkgname-$pkgver.tar.gz)
+md5sums=('ab2ba9ba24c9dbb3def3ac7878c33bbb')
+
+check() {
+ cd "${srcdir}"/$_pkgname-$pkgver
+
+ python2 runtests.py
+ python runtests.py
+}
+
+package_python2-django-taggit() {
+ depends=('python2-django')
+
+ cd "${srcdir}"/$_pkgname-$pkgver
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python-django-taggit() {
+ depends=('python-django')
+
+ cd "${srcdir}"/$_pkgname-$pkgver
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+}