summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJingbei Li2023-05-06 13:32:44 +0800
committerJingbei Li2023-05-06 13:32:44 +0800
commit2d701d1f4a2c764b0eee27aadffcba54668f7c3d (patch)
tree975e7f214a116aaca111363f3b79b32b6f81a9f9 /PKGBUILD
parent995f202165b469d1494c8468366375a45febaa0c (diff)
downloadaur-2d701d1f4a2c764b0eee27aadffcba54668f7c3d.tar.gz
upgraded to 19.24.1, changed to pypi source
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3199decdcd3..db3f6afb242d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgbase=python-dlib
pkgname=('python-dlib')
##pkgname+=('python-dlib-cuda')
_pkgname=dlib
-pkgver=19.24
+pkgver=19.24.1
pkgrel=1
pkgdesc="Dlib is a general purpose cross-platform C++ library designed using contract programming and modern C++ techniques."
arch=('x86_64')
@@ -19,14 +19,15 @@ depends=('cblas' 'giflib' 'lapack' 'libjpeg-turbo' 'libpng' 'libx11')
optdepends=('sqlite')
##optdepends+=('cuda' 'cudnn' 'ccache-ext')
makedepends=(${optdepends[@]} 'cmake' 'boost' 'python-setuptools')
-source=("$url/files/${_pkgname}-${pkgver}.tar.bz2")
-sha256sums=('28fdd1490c4d0bb73bd65dad64782dd55c23ea00647f5654d2227b7d30b784c4')
+#source=("$url/files/${_pkgname}-${pkgver}.tar.bz2")
+source=("https://pypi.io/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('e8d3ca047d525eeb36cc47bce45ed0562dab40b0b8f5fa171600dde2fec509c0')
##options=(!lto)
-prepare() {
- cd "$srcdir/"
- cp -a "${_pkgname}-${pkgver}" "${_pkgname}-${pkgver}-cuda"
-}
+##prepare() {
+## cd "$srcdir/"
+## cp -a "${_pkgname}-${pkgver}" "${_pkgname}-${pkgver}-cuda"
+##}
build(){
cd "${srcdir}/${_pkgname}-${pkgver}"