summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2021-04-14 22:27:39 -0400
committerGuillaume Horel2021-04-14 22:27:39 -0400
commit1bbb1e97ea12f421260727a86b3d6ebc19bf5747 (patch)
treec41ffea06f1565d02b4c3f73eb602c26ac435353 /PKGBUILD
downloadaur-1bbb1e97ea12f421260727a86b3d6ebc19bf5747.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ecbbcec8ef4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname='python-docformatter'
+_pkgname='docformatter'
+pkgver=1.4
+pkgrel=1
+pkgdesc='Format docstrings to follow PEP257'
+url='https://github.com/myint/docformatter'
+checkdepends=()
+depends=('python-untokenize')
+makedepends=('python-setuptools')
+optdepends=()
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('064e6d81f04ac96bc0d176cbaae953a0332482b22d3ad70d47c8a7f2732eef6f')
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+check() {
+ cd "$_pkgname-$pkgver"
+ python test_docformatter.py
+}
+