summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNathan Owens2020-04-28 23:57:26 -0500
committerNathan Owens2020-04-28 23:57:26 -0500
commit85a768e1d0f41f94b9a91ccee48f41c08b498494 (patch)
tree4de9c062b71e1e689ae9ab537a845039d2cdde51 /PKGBUILD
parent90085916ea7ac48d61114086fffb60eac0f94ae6 (diff)
downloadaur-85a768e1d0f41f94b9a91ccee48f41c08b498494.tar.gz
Update to 0.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 297171d2e167..4d5b85c8e531 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
-_pkgname=dodgy
pkgname=python-dodgy
-pkgver=0.1.9
+pkgver=0.2.1
pkgrel=1
pkgdesc="Looks at Python code to search for things which look dodgy such as passwords or diffs"
arch=('any')
url="https://github.com/landscapeio/dodgy"
license=('MIT')
depends=('python')
-makedepends=('python-setuptools')
-source=(https://github.com/landscapeio/dodgy/archive/${pkgver}.tar.gz)
-md5sums=('fd268f48162cc6a5dc62f784b7d61e85')
+makedepends=('python-setuptools' 'git')
+source=(git+https://github.com/landscapeio/dodgy#tag=${pkgver})
+sha256sums=('SKIP')
build() {
- cd "${_pkgname}-${pkgver}"
+ cd "dodgy"
python setup.py build
}
package() {
- cd "${_pkgname}-${pkgver}"
+ cd "dodgy"
- python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
- install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+ python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+ install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
}
-# vim:set ts=2 sw=2 et: