summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSven-Hendrik Haase2016-06-28 01:34:31 +0200
committerSven-Hendrik Haase2016-06-28 01:34:35 +0200
commit90085916ea7ac48d61114086fffb60eac0f94ae6 (patch)
tree5b1bcf8b8219a133c175bf2e003013866ea3122f /PKGBUILD
downloadaur-90085916ea7ac48d61114086fffb60eac0f94ae6.tar.gz
Push python-dodgy
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..297171d2e167
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+
+_pkgname=dodgy
+pkgname=python-dodgy
+pkgver=0.1.9
+pkgrel=1
+pkgdesc="Looks at Python code to search for things which look dodgy such as passwords or diffs"
+arch=('any')
+url="https://github.com/landscapeio/dodgy"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=(https://github.com/landscapeio/dodgy/archive/${pkgver}.tar.gz)
+md5sums=('fd268f48162cc6a5dc62f784b7d61e85')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+
+ python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+ install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+}
+# vim:set ts=2 sw=2 et: