summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Warrick2016-11-22 16:21:40 +0100
committerChris Warrick2016-11-22 16:21:40 +0100
commit05042df35e5420ea3bae707dbd1b2b618a8b65b8 (patch)
tree818dc2d75a46c688365a9a57dbdbbfcd8f169263 /PKGBUILD
parent087072cb7208dcdc27440376e197bcfbb7558f7d (diff)
downloadaur-05042df35e5420ea3bae707dbd1b2b618a8b65b8.tar.gz
python-doit v0.30.0 (split package replaced by two packages due to py2 incompatibility)
Signed-off-by: Chris Warrick <kwpolska@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 6 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae87907d28bb..650ffa17f4b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,18 @@
# Maintainer: Chris Warrick <aur@chriswarrick.com>
-pkgbase=python-doit
-pkgname=('python-doit' 'python2-doit')
+pkgname=python-doit
_pyname=doit
-pkgver=0.29.0
-pkgrel=3
+pkgver=0.30.0
+pkgrel=1
pkgdesc='doit automation tool'
arch=('any')
url='http://pydoit.org/'
license=('MIT')
-makedepends=('python' 'python2' 'python-setuptools' 'python2-setuptools'
- 'python-pyinotify' 'python-six' 'python-cloudpickle'
- 'python2-pyinotify' 'python2-six' 'python2-cloudpickle')
options=(!emptydirs)
source=("https://pypi.io/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('9968e1a669bad0a999212ab9f5c591a3')
+depends=('python' 'python-pyinotify' 'python-six' 'python-setuptools' 'python-cloudpickle')
+md5sums=('fc312758d97e8a86da9c1e130a0bc572')
-prepare() {
- cd "${srcdir}/${_pyname}-${pkgver}"
- cp -r "${srcdir}/${_pyname}-${pkgver}" "${srcdir}/${_pyname}-${pkgver}-py2"
-}
-
-package_python-doit() {
- depends=('python' 'python-pyinotify' 'python-six' 'python-setuptools' 'python-cloudpickle')
+package() {
cd "${srcdir}/${_pyname}-${pkgver}"
python3 setup.py install --root="${pkgdir}/" --optimize=1
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
@@ -30,11 +21,4 @@ package_python-doit() {
install -D -m755 'bash_completion_doit' "${pkgdir}/usr/share/bash-completion/completions/${_pyname}"
}
-package_python2-doit() {
- depends=('python2' 'python2-pyinotify' 'python2-six' 'python2-setuptools' 'python2-cloudpickle')
- cd "${srcdir}/${_pyname}-${pkgver}-py2"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
- mv "${pkgdir}/usr/bin/${_pyname}" "${pkgdir}/usr/bin/${_pyname}2"
-}
-
# vim:set ts=2 sw=2 et: