summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Warrick2014-12-31 11:00:34 +0100
committerChris Warrick2014-12-31 11:00:34 +0100
commit38eb266908f0e89c776eb10bc8bf07d157874f1d (patch)
tree59f3ee8f338dc99103eafca6c1449465236bd641 /PKGBUILD
downloadaur-38eb266908f0e89c776eb10bc8bf07d157874f1d.tar.gz
init python-doit
Signed-off-by: Chris Warrick <kwpolska@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f13cf5f9f1fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Chris Warrick <aur@chriswarrick.com>
+pkgname=python-doit
+_pyname=doit
+pkgver=0.26.0
+pkgrel=1
+pkgdesc='Automation Tool'
+arch=('any')
+url='http://pydoit.org/'
+license=('MIT')
+depends=('python' 'python-pyinotify' 'python-six')
+options=(!emptydirs)
+source=("http://pypi.python.org/packages/source/$(echo ${_pyname} | cut -c1)/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+ "LICENSE")
+md5sums=('24d83f64024649e701f4dd2f0e391980'
+ '7d6fd7c8e022bae9010af272c31eb45f')
+
+package() {
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python3 setup.py install --root="${pkgdir}/" --optimize=1
+ install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: