summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Warrick2015-07-29 13:06:13 +0200
committerChris Warrick2015-07-29 13:06:22 +0200
commit3df8dd1d10bd5261a48ededa8504546619a94825 (patch)
treec3aef3fb43c47fbe455cd7ada0b905e038e9520c /PKGBUILD
parent3d697b214ba5075bab2bf88b253de2e5d40fec4d (diff)
downloadaur-3df8dd1d10bd5261a48ededa8504546619a94825.tar.gz
add bash/zsh completion
Signed-off-by: Chris Warrick <kwpolska@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9eab6052f841..8d7115f69c0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-doit
pkgname=('python-doit' 'python2-doit')
_pyname=doit
pkgver=0.28.0
-pkgrel=1
+pkgrel=2
pkgdesc='doit automation tool'
arch=('any')
url='http://pydoit.org/'
@@ -27,6 +27,10 @@ package_python-doit() {
python3 setup.py install --root="${pkgdir}/" --optimize=1
install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
ln -s ${_pyname} "${pkgdir}/usr/bin/${_pyname}3"
+ install -D -m755 'zsh_completion_doit'
+ "${pkgdir}/usr/share/zsh/site-functions/_${_pyname}"
+ install -D -m755 'bash_completion_doit'
+ "${pkgdir}/usr/share/bash-completion/completions/${_pyname}"
}
package_python2-doit() {