summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Warrick2015-08-20 16:58:15 +0200
committerChris Warrick2015-08-20 16:58:53 +0200
commit83d388b6210a2f095c7ab59bc3cb2484ac45f6b5 (patch)
treed36a1b9d0099f43030498643ab0dbda62fb876a6 /PKGBUILD
parentae3723ad95f34f6eed6de558296408602cadf5e8 (diff)
downloadaur-83d388b6210a2f095c7ab59bc3cb2484ac45f6b5.tar.gz
add missing cloudpickle dependency
Signed-off-by: Chris Warrick <kwpolska@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6f8c4f78c74..b6aed954ca95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,17 @@ pkgbase=python-doit
pkgname=('python-doit' 'python2-doit')
_pyname=doit
pkgver=0.29.0
-pkgrel=1
+pkgrel=2
pkgdesc='doit automation tool'
arch=('any')
url='http://pydoit.org/'
license=('MIT')
makedepends=('python' 'python2' 'python-setuptools' 'python2-setuptools'
- 'python-pyinotify' 'python-six' 'python2-pyinotify' 'python2-six')
+ 'python-pyinotify' 'python-six' 'python-cloudpickle'
+ 'python2-pyinotify' 'python2-six' 'python2-cloudpickle')
options=(!emptydirs)
-source=("https://pypi.python.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
- "LICENSE")
-md5sums=('9968e1a669bad0a999212ab9f5c591a3'
- '7d6fd7c8e022bae9010af272c31eb45f')
+source=("https://pypi.python.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('9968e1a669bad0a999212ab9f5c591a3')
prepare() {
cd "${srcdir}/${_pyname}-${pkgver}"
@@ -22,17 +21,17 @@ prepare() {
}
package_python-doit() {
- depends=('python' 'python-pyinotify' 'python-six' 'python-setuptools')
+ depends=('python' 'python-pyinotify' 'python-six' 'python-setuptools' 'python-cloudpickle')
cd "${srcdir}/${_pyname}-${pkgver}"
python3 setup.py install --root="${pkgdir}/" --optimize=1
- install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
ln -s ${_pyname} "${pkgdir}/usr/bin/${_pyname}3"
install -D -m755 'zsh_completion_doit' "${pkgdir}/usr/share/zsh/site-functions/_${_pyname}"
install -D -m755 'bash_completion_doit' "${pkgdir}/usr/share/bash-completion/completions/${_pyname}"
}
package_python2-doit() {
- depends=('python2' 'python2-pyinotify' 'python2-six' 'python2-setuptools')
+ depends=('python2' 'python2-pyinotify' 'python2-six' 'python2-setuptools' 'python2-cloudpickle')
cd "${srcdir}/${_pyname}-${pkgver}-py2"
python2 setup.py install --root="${pkgdir}/" --optimize=1
mv "${pkgdir}/usr/bin/${_pyname}" "${pkgdir}/usr/bin/${_pyname}2"