summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlberto Redondo2021-02-23 17:48:36 +0100
committerAlberto Redondo2021-02-23 17:48:36 +0100
commit4b405ca8b184a60151a5d022eedbfa0883266408 (patch)
tree205b4ca7a1f76a42cbf76e5027619762139e597e /PKGBUILD
downloadaur-4b405ca8b184a60151a5d022eedbfa0883266408.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25a8badf7762
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Alberto Redondo <albertomost at gmail dot com>
+
+_pkgname=domain-connect-dyndns
+_pkgname_gh=DomainConnectDDNS-Python
+pkgname=python-${_pkgname}
+pkgver=0.0.8
+pkgrel=1
+pkgdesc='Python client library for Dynamic DNS using Domain Connect'
+arch=('any')
+url='https://github.com/Domain-Connect/DomainConnectDDNS-Python'
+_url_pypi='https://pypi.org/project/domain-connect-dyndns'
+license=('MIT')
+depends=(
+ 'python'
+ 'python-validators'
+ 'python-requests'
+ 'python-dnspython'
+ 'python-domain-connect'
+)
+makedepends=('python-setuptools')
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+md5sums=('9ec626ce5189e4072d723f2e25a40ed1')
+
+build() {
+
+ cd ${_pkgname_gh}-${pkgver}
+
+ python setup.py build
+
+}
+
+package() {
+
+ cd ${_pkgname_gh}-${pkgver}
+
+ python setup.py install \
+ -O1 \
+ --root="${pkgdir}" \
+ --skip-build
+
+ install -Dm644 LICENSE \
+ -t "${pkgdir}/usr/share/licenses/${pkgname}"
+
+}