summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2022-03-12 21:17:17 +0800
committerUniversebenzene2022-03-12 21:17:17 +0800
commitdfc07b4912d78dca2c228edafcece923ec244b1e (patch)
treea2a113796595b5a7cf1d56ad89f0cbb94506dff3 /PKGBUILD
parentf592675f358996679c2a7e1c6f9fb05c436d7703 (diff)
downloadaur-dfc07b4912d78dca2c228edafcece923ec244b1e.tar.gz
Update to version 3.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 36 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1bddf7ad94a3..314b63904425 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,20 @@ pkgbase=python-drizzlepac
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=3.3.1
+pkgver=3.4.0
pkgrel=1
pkgdesc="AstroDrizzle for HST images"
arch=('i686' 'x86_64')
url="http://www.stsci.edu/scientific-community/software/drizzlepac.html"
license=('BSD')
-makedepends=('python-setuptools'
- 'python-relic'
- 'python-astropy')
+makedepends=('python-setuptools-scm>=3.4'
+ 'python-wheel'
+ 'python-build'
+ 'python-installer'
+ 'python-numpy'
+ 'python-astropy>=4.3'
+ 'python-markupsafe<=2.0.1')
+# 'python-relic'
# 'python-numpydoc'
# 'python-sphinx_rtd_theme'
# 'python-stsci_rtd_theme'
@@ -31,10 +36,12 @@ checkdepends=('python-pytest-remotedata'
'python-matplotlib'
'python-scikit-learn'
'python-scikit-image'
+ 'python-spherical_geometry'
+ 'python-stwcs'
'python-stsci.skypac'
'python-ci_watson'
'python-fitsblender'
- 'python-nictools'
+# 'python-nictools'
'python-stsci.image'
'python-stregion'
'python-tweakwcs'
@@ -46,36 +53,47 @@ checkdepends=('python-pytest-remotedata'
'python-crds')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
"https://raw.githubusercontent.com/spacetelescope/drizzlepac/master/tests/hap/ACSWFC3ListDefault50.csv")
-md5sums=('c8d3650b41ace7340689d378750730b0'
+md5sums=('5a796f4a70b61c7a42512bcd88863bdd'
'acaf7d8bcf0f6244042bba0df3d03679')
prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ sed -i "/oldest-supported-numpy/d" pyproject.toml
export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
}
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
# msg "Building Docs"
# python setup.py build_sphinx
}
check() {
- export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
- cd ${srcdir}/${_pyname}-${pkgver}/build/lib.linux-${CARCH}-${_pyver}
+ cd ${srcdir}/${_pyname}-${pkgver}
- ln -rs ${srcdir}/ACSWFC3ListDefault50.csv tests/hap
- pytest || warning "Tests failed"
+ ln -rs ${srcdir}/ACSWFC3ListDefault50.csv "build/lib.linux-${CARCH}-${_pyver}/tests/hap"
+ # skip some tests that need lots of online data or cost lots of time; some files are missing in pypi package
+ pytest "build/lib.linux-${CARCH}-${_pyver}" \
+ --ignore=build/lib.linux-${CARCH}-${_pyver}/tests/hap/test_svm_canary.py \
+ --ignore=build/lib.linux-${CARCH}-${_pyver}/tests/hap/test_svm_hrcsbc.py \
+ --ignore=build/lib.linux-${CARCH}-${_pyver}/tests/hap/test_svm_ibqk07.py \
+ --ignore=build/lib.linux-${CARCH}-${_pyver}/tests/hap/test_svm_ibyt50.py \
+ --ignore=build/lib.linux-${CARCH}-${_pyver}/tests/hap/test_svm_j97e06.py \
+ --ignore=build/lib.linux-${CARCH}-${_pyver}/tests/hap/test_svm_je281u.py \
+ --ignore=build/lib.linux-${CARCH}-${_pyver}/tests/hap/test_svm_wfc3ir.py \
+ --deselect=build/lib.linux-${CARCH}-${_pyver}/tests/hap/test_pipeline.py::TestSingleton::test_astrometric_singleton[iaaua1n4q] \
+ --deselect=build/lib.linux-${CARCH}-${_pyver}/tests/hap/test_pipeline.py::TestSingleton::test_astrometric_singleton[iacs01t4q] || warning "Tests failed"
}
package_python-drizzlepac() {
- depends=('python>=3.7'
+ depends=('python>=3.8'
'python-scipy'
'python-matplotlib'
'python-requests'
'python-scikit-learn>=0.20'
- 'python-spherical_geometry>=1.2.17'
'python-stsci.tools>=4.0'
'python-stsci.image>=2.3.4'
'python-stsci.imagestats'
@@ -84,13 +102,14 @@ package_python-drizzlepac() {
'python-stwcs>=1.5.3'
'python-tweakwcs>=0.7.2'
'python-stregion'
- 'python-fitsblender'
- 'python-acstools'
- 'python-nictools')
+ 'python-fitsblender')
+# 'python-acstools'
+# 'python-nictools')
optdepends=('python-astroquery>=0.4: HAP-pipeline specific'
'python-photutils>=1.0.0: HAP-pipeline specific'
'python-bokeh: HAP-pipeline specific'
'python-pandas: HAP-pipeline specific'
+ 'python-spherical_geometry>=1.2.22: HAP-pipeline specific'
'python-pypdf2: HAP-pipeline specific'
'python-pytables: HAP-pipeline specific'
'python-yaml: HAP-pipeline specific'
@@ -103,7 +122,7 @@ package_python-drizzlepac() {
install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE.txt
install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
rm "${pkgdir}/usr/lib/python${_pyver}/site-packages/tests/__init__.py"
rm "${pkgdir}/usr/lib/python${_pyver}/site-packages/tests/__pycache__"/__init__*
}