summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2018-11-12 16:51:52 +0000
committerGrey Christoforo2018-11-12 16:54:37 +0000
commit1ca7a070ab3d9f2126338be461e06e3714c1c833 (patch)
tree4782f7c4591a8e13e6274a9e3dedb8644aa00feb /PKGBUILD
downloadaur-1ca7a070ab3d9f2126338be461e06e3714c1c833.tar.gz
initial commit
add srcinfo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..259e2b94b0e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=python-dxfgrabber
+_module='dxfgrabber'
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A Python library to grab information from DXF drawings - all DXF versions supported."
+url="https://github.com/mozman/dxfgrabber.git"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/d0/d5/f4c1bc143223b4a2cc4e915e7e1956ef183fbe035e4a8525e336110a90ed/dxfgrabber-${pkgver}.zip")
+md5sums=('d87f166fe168ef8ab58c837cedd0c370')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}