summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTjw123hh2025-01-28 13:40:18 +0800
committerTjw123hh2025-01-28 13:41:35 +0800
commite989a1c81fedd54cb211ffa2b50a8953eeac829e (patch)
tree7650bf9d7f799f8c33641dbe3a69b9fac1fae5d2 /PKGBUILD
downloadaur-e989a1c81fedd54cb211ffa2b50a8953eeac829e.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d0c4c15058f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Tjw123hh Pigmonky <tjw123hh@outlook.com>
+pkgname=python-east-asian-spacing-git
+_name=${pkgname#python-}
+_name=${_name//-/_}
+pkgver=1.4.2.r97.g2a1d8a7
+pkgrel=1
+pkgdesc="East Asian Contextual Spacing Build Tools"
+arch=('any')
+url="https://github.com/kojiishi/east_asian_spacing"
+license=('Apache-2.0')
+depends=('python'
+ 'python-fonttools'
+ 'python-brotli'
+ 'python-zopfli'
+ 'python-uharfbuzz')
+makedepends=('python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'python-poetry-core')
+checkdepends=('python-pytest'
+ 'python-pytest-asyncio')
+provides=(${pkgname%-*}=$pkgver)
+conflicts=(${pkgname%-*})
+source=("$pkgname-$pkgver::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname-$pkgver
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd $pkgname-$pkgver
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd $pkgname-$pkgver
+ python tests/download_fonts.py
+ PYTHONPATH="$PWD" pytest
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}