summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjem2019-06-10 15:57:36 +1000
committerjem2019-06-10 15:57:36 +1000
commita14e1375f710da9bdac24330a113bca1172a2524 (patch)
treeb78765d83f0960bbab1b3dbadf5f62746f886727 /PKGBUILD
downloadaur-python-easyhid.tar.gz
init commit for python-easyhid PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d9406411792
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: jem <jem ΑΤ seethis DΟΤ link>
+pkgname=python-easyhid
+pkgver=0.0.10
+pkgrel=1
+epoch=
+pkgdesc="simple library for reading/writing to HID devices"
+arch=('any')
+url="https://github.com/ahtn/python-easyhid"
+license=('MIT')
+groups=()
+depends=('python-cffi' 'hidapi')
+makedepends=('python' 'python-setuptools')
+checkdepends=()
+optdepends=()
+provides=('python-easyhid')
+conflicts=('python-easyhid')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(
+ "${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
+)
+sha512sums=(
+ '17f21c16699e45972d9a7a87719e16ec4f60a2a9d0b863a94ac092c585fee682d75adc2cbc3bc5f000a1b8299869526c7644d585bf9ef3a5de653e48d756f75b'
+)
+noextract=()
+validpgpkeys=()
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}