summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2023-05-13 21:45:02 -0700
committerGI_Jack2023-05-13 21:45:02 -0700
commit987fe99f09313a8010ac438a0e402715a8f8f99a (patch)
tree1e2504c272750642f280f8ab136438da91f1a97f /PKGBUILD
parentd36097866685fcee63578b9e7bd2856cf8028f93 (diff)
downloadaur-python-ecpy.tar.gz
version 1.2.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 836b49f9acc9..fe7e82c320f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
# Maintainer: GI Jack <GI_Jack@hackermail.com>
-pkgbase=python-ecpy
pkgname='python-ecpy'
+_pkgname='ECPy'
pkgver=1.2.5
-pkgrel=1
+pkgrel=2
arch=('any')
pkgdesc='Pure Python Elliptic Curve Library for Python'
url='https://github.com/ubinity/ECPy'
license=('custom')
-source=("${pkgname}-${pkgver}::https://github.com/cslashm/ECPy/archive/1.2.5.tar.gz")
+source=("${pkgname}-${pkgver}::https://github.com/cslashm/${_pkgname}/archive/1.2.5.tar.gz")
sha256sums=('02a2e990fe4b9c51a5a2d7518439ad80e5d839c931f76fa5144c50543e6a103f')
-makedepends=('python' 'python-setuptools' 'python-future')
+depends=('python' 'python-future')
+makedepends=('python-build' 'python-installer' 'python-wheel')
build() {
- cd ECPy-${pkgver}
- python setup.py build
+ cd "${_pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
}
package() {
- cd ECPy-${pkgver}
- python setup.py install --root="${pkgdir}" --optimize=1
- # Install License
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- # Install Documentation
- install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+ cd "${_pkgname}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ # Install License
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Install Documentation
+ install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
}
-