summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2020-11-15 11:21:54 -0500
committerGI_Jack2020-11-15 11:21:54 -0500
commitda23a7a901a675d220736c3146d29cac8a4685a4 (patch)
tree296d9b4d1930de59fc16efa5df34c36e7f5042d5 /PKGBUILD
downloadaur-da23a7a901a675d220736c3146d29cac8a4685a4.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6855f22bdb6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: GI Jack <GI_Jack@hackermail.com>
+
+pkgbase=python-ecpy
+pkgname='python-ecpy'
+pkgver=1.2.5
+pkgrel=1
+arch=('any')
+pkgdesc='Pure Python Elliptic Curve Library for Python'
+url='https://github.com/ubinity/ECPy'
+license=('custom')
+source=("${pkgname}-${pkgver}::https://github.com/cslashm/ECPy/archive/1.2.5.tar.gz")
+sha256sums=('02a2e990fe4b9c51a5a2d7518439ad80e5d839c931f76fa5144c50543e6a103f')
+makedepends=('python' 'python-setuptools' 'python-future')
+
+build() {
+ cd ECPy-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ECPy-${pkgver}
+ python setup.py install --root="${pkgdir}" --optimize=1
+ # Install License
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Install Documentation
+ install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}
+
+
+