summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCayetano Santos2020-04-29 20:02:35 +0200
committerCayetano Santos2020-04-29 20:02:35 +0200
commit21ba41c1aba4d7661f2587b6010d2301e249a6b0 (patch)
treebf00e08a6d67fedb0bce4fee4f62c6f3dbed88f1 /PKGBUILD
parentcff030a1a0ed5605675bfe941bf31fdee176fa5b (diff)
downloadaur-21ba41c1aba4d7661f2587b6010d2301e249a6b0.tar.gz
depends on jinja in the repos
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 1 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a6be26c0358..2fdce72f204f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url="https://github.com/olofk/edalize"
license=('BSD')
conflicts=('python-edalize')
provides=('python-edalize-git')
-depends=('python' 'python-pytest' 'python-setuptools')
+depends=('python' 'python-pytest' 'python-setuptools' 'python-jinja')
makedepends=('git')
optdepends=('iverilog: for simulating verilog designs'
@@ -25,8 +25,6 @@ build() {
}
package() {
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps Jinja2
- python -O -m compileall "${pkgdir}/jinja2"
cd "${srcdir}/edalize"
python setup.py install --skip-build --root="$pkgdir" --optimize=1
install -m 644 -D ./LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE