summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCayetano Santos2020-03-21 12:41:18 +0100
committerCayetano Santos2020-03-21 12:41:18 +0100
commit62583ec2dc56669c5bab6133caf014dcf30dfdb7 (patch)
tree0841b9365552e213e4a9f490ce53a0a18873dcd7 /PKGBUILD
parente4307e69da417ba3e9f2ff00ead2529f3e77b08b (diff)
downloadaur-62583ec2dc56669c5bab6133caf014dcf30dfdb7.tar.gz
Cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d22386228ca..23ec584ff13a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,19 +12,20 @@ depends=('python' 'python-pytest')
makedepends=('git' 'python-setuptools')
optdepends=('iverilog: for simulating verilog designs'
- 'ghdl: for simulating VHDL designs')
+ 'ghdl: for simulating VHDL designs'
+ 'gtkwave: for visualizing waveforms')
options=(!emptydirs)
source=('git+https://github.com/olofk/edalize')
sha256sums=('SKIP')
-pkgver() {
- cd "${srcdir}/edalize"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
package() {
cd "${srcdir}/edalize"
python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
install -m 644 -D ./LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}
+
+pkgver() {
+ cd "${srcdir}/edalize"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
} \ No newline at end of file