summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorspecter1192019-04-13 17:06:12 +0800
committerspecter1192019-04-13 17:06:12 +0800
commitf6cbf1f27e3379bf392e4cd21639607a6469baed (patch)
treedd027197516848ff4e5c6e876261505dc0cf42ad /PKGBUILD
parent4f139c3e0296477d04f052e0337497d8622f039f (diff)
downloadaur-f6cbf1f27e3379bf392e4cd21639607a6469baed.tar.gz
remove sed from makedepends, since upstream remove typing.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 160d4efff209..5f20eb52de5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ke Liu <spcter119@gmail.com>
pkgname=python-ehforwarderbot-git
-pkgver=r385.c1af67e
+pkgver=r386.59c52e6
pkgrel=1
pkgdesc='An extensible message tunneling chat bot framework. Delivers messages to and from multiple platforms and remotely control your accounts.'
arch=('any')
@@ -9,7 +9,7 @@ url='https://github.com/blueset/ehForwarderBot'
license=('AGPL-3')
groups=('efb')
depends=('python-ruamel-yaml' 'python-asciimatics' 'python-cjkwrap' 'python-typing-extensions')
-makedepends=('git' 'sed')
+makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("${pkgname%-git}"::"git+${url}.git"
@@ -24,8 +24,6 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- sed -i '/^typing$/d' "$srcdir/${pkgname%-git}/requirements.txt"
- sed -i '/"typing",/d' "$srcdir/${pkgname%-git}/setup.py"
python setup.py clean --all
python setup.py build
}