summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2020-08-31 19:45:51 +0800
committerUniversebenzene2020-08-31 19:45:51 +0800
commit760cdae0bde4b3d75129892da02fec9e2373f6d6 (patch)
treef2a52276482880fc11200f346da998bd5f9b0fa2 /PKGBUILD
downloadaur-python-einsteinpy_geodesics-doc.tar.gz
Initial import 0.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38e71b8bec53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+_pyname=einsteinpy-geodesics
+pkgname=python-${_pyname/-/_}-doc
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Documentation for EinsteinPy Geodesics"
+arch=('i686' 'x86_64')
+url="https://docs.geodesics.einsteinpy.org"
+license=('MIT')
+makedepends=("python-${_pyname/-/_}=${pkgver}" 'python-sphinx')
+#'python-nbsphinx' 'pandoc' 'graphviz')
+source=("https://github.com/einsteinpy/einsteinpy-geodesics/archive/v${pkgver}.tar.gz")
+md5sums=('5c43ab1cd6ebeef77cf156bd098abe03')
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}/docs
+
+ make html
+}
+
+package() {
+ cd ${srcdir}/${_pyname}-${pkgver}/docs/build
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+ install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../../COPYING
+}