summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorneodarz2020-06-04 16:58:51 +0200
committerneodarz2020-06-04 16:58:51 +0200
commit8eef70dc93ee11b8e086cf20905722c36c803ec0 (patch)
tree30fc60307f163ca27c5ad39f1cd53d96bdacf72d /PKGBUILD
downloadaur-8eef70dc93ee11b8e086cf20905722c36c803ec0.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7ede716df4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: neodarz <neodarz at neodarz dot net>
+
+_pkgname=eradicate
+pkgname=python-$_pkgname
+
+pkgver=1.0
+pkgrel=1
+pkgdesc="Removes commented-out code from Python files"
+
+url='https://github.com/myint/eradicate'
+arch=('any')
+license=('MIT')
+
+depends=('python')
+
+source=("https://github.com/myint/$_pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('720662c25a571791d9ffe15aaaff7b67f5c73945a855defb7b0dec9379031eb9f1d5e5b9b132ba520a0ff14e5af1eb2e110aeb2621a0df75b5cc16c93307ab6a')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}