summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-12 14:46:01 -0500
committerCarlos Aznarán Laos2022-01-12 14:46:01 -0500
commita96f2dfd35a57693c9519c75f3c6cfc85ff5e9de (patch)
treeb39310591437ccc9f20591a13d42c7a44728fbea /PKGBUILD
parent0d569310ac2a7003cce7a68a8de3be34e343ae1a (diff)
downloadaur-a96f2dfd35a57693c9519c75f3c6cfc85ff5e9de.tar.gz
Version bump to 3.1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD78
1 files changed, 26 insertions, 52 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0de8d86e2119..53e5ca37f54f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,31 @@
-# Maintainer: Clint Valentine <valentine.clint@gmail.com>
-
-_name=ete3
-pkgbase='python-ete'
-pkgname=('python-ete' 'python2-ete')
-pkgver=3.1.1
-pkgrel=2
-pkgdesc="Python toolkit for building, comparing, annotating, manipulating and visualising phylogenetic trees"
+# Contributor: Clint Valentine <valentine.clint@gmail.com>
+_base=ete3
+pkgname=python-${_base/3/}
+pkgver=3.1.2
+pkgrel=1
+pkgdesc="A Python Environment for (phylogenetic) Tree Exploration"
arch=('any')
-url=http://etetoolkit.org/
-license=('GPL3')
-makedepends=(
- 'python' 'python-setuptools'
- 'python2' 'python2-setuptools')
-options=(!emptydirs)
-source=("${pkgname}"-"${pkgver}".tar.gz::https://pypi.python.org/packages/21/17/3c49b7fafe10ed63bb7904ebf9764b98db726aa5fd482fb006818854bc04/ete3-3.1.1.tar.gz)
-sha256sums=('870a3d4b496a36fbda4b13c7c6b9dfa7638384539ae93551ec7acb377fb9c385')
-
-prepare() {
- cp -a "${_name}"-"${pkgver}"{,-py2}
-}
-
-build(){
- cd "${srcdir}"/"${_name}"-"${pkgver}"
+url="http://${_base/3/}toolkit.org"
+license=(GPL)
+depends=(python-six)
+makedepends=(python-setuptools)
+optdepends=(
+ 'python-lxml: Nexml and Phyloxml support'
+ 'python-numpy: ArrayTable and ClusterTree class support'
+ 'python-pyqt5: tree visualization and image rendering'
+)
+# options=(!emptydirs)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('e21d47ff4ec0f7669beb88e9526b33fed7c802e610277c2e09436e54b127b06439c49b4ad82316fe1e08bc0a40635b822949ec51f60b1ab2d604069988a212a4')
+
+build() {
+ cd "${_base}-${pkgver}"
python setup.py build
-
- cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
- python2 setup.py build
}
-package_python2-ete() {
- depends=('python2' 'python2-six')
- optdepends=(
- 'python2-lxml: Nexml and Phyloxml support'
- 'python2-numpy: ArrayTable and ClusterTree class support'
- 'python2-pyqt4: tree visualization and image rendering'
- 'python2-pyqt5: tree visualization and image rendering'
- )
-
- cd "${_name}"-"${pkgver}"-py2
- python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
-
- mv "${pkgdir}"/usr/bin/"${_name}" "${pkgdir}"/usr/bin/"${_name}"-2
-}
-
-package_python-ete() {
- depends=('python' 'python-six')
- optdepends=(
- 'python-lxml: Nexml and Phyloxml support'
- 'python-numpy: ArrayTable and ClusterTree class support'
- 'python-pyqt4: tree visualization and image rendering'
- 'python-pyqt5: tree visualization and image rendering'
- )
-
- cd "${_name}"-"${pkgver}"
- python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+package() {
+ cd "${_base}-${pkgver}"
+ export PYTHONHASHSEED=0
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}